静态路由实现主备备份

组网图形

    

静态路由简介

  • 静态路由是一种需要管理员手工配置的特殊路由。静态路由比动态路由使用更少的带宽,并且不占用CPU资源来计算和更新路由。但是当网络发生故障或者拓扑发生变化后,静态路由不会自动更新,必须手动重新配置。静态路由有5个主要的参数:目的地址和掩码、出接口和下一跳、优先级。
  • 使用静态路由的好处是配置简单、可控性高,当网络结构比较简单时,只需配置静态路由就可以使网络正常工作。在复杂网络环境中,还可以通过配置静态路由改进网络的性能,并且可以为重要的应用保证带宽。

组网需求

  • 如图1所示,PC1和PC2通过4台Switch相连,从拓扑图中可以看出,数据从PC1到PC2有两条路径可以到达,分别是PC1-SwitchA-SwitchB-SwitchC-PC2和PC1-SwitchA-SwitchD-SwitchC-PC2,用户希望要求从PC1到PC2的数据流实现主备备份,即优先走经过SwitchB的这条路径,当这条路径故障的时候流量自动切换到经过SwitchD的这条路径。

配置思路

  • 1.创建VLAN并配置各接口所属VLAN,配置各VLANIF接口的IP地址。
  • 2.配置数据流来回两个方向的静态路由。
  • 3.在各主机上配置IP地址和默认网关。

操作步骤

  • 1.配置各接口所属VLAN

  # 配置SwitchA。SwitchB、SwitchC和SwitchD的配置与SwitchA类似,不再赘述。

<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] vlan batch 10 100 400
[SwitchA] interface gigabitethernet 0/0/1
[SwitchA-GigabitEthernet0/0/1] port link-type access
[SwitchA-GigabitEthernet0/0/1] port default vlan 10
[SwitchA-GigabitEthernet0/0/1] quit
[SwitchA] interface gigabitethernet 0/0/2
[SwitchA-GigabitEthernet0/0/2] port link-type trunk
[SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
[SwitchA-GigabitEthernet0/0/2] quit
[SwitchA] interface gigabitethernet 0/0/3
[SwitchA-GigabitEthernet0/0/3] port link-type trunk
[SwitchA-GigabitEthernet0/0/3] port trunk allow-pass vlan 400
[SwitchA-GigabitEthernet0/0/3] quit
  •  2.配置各VLANIF接口的IP地址

  # 配置SwitchA。SwitchB、SwitchC和SwitchD的配置与SwitchA类似,不再赘述。

[SwitchA] interface vlanif 10
[SwitchA-Vlanif10] ip address 10.1.1.1 24
[SwitchA-Vlanif10] quit
[SwitchA] interface vlanif 100
[SwitchA-Vlanif100] ip address 192.168.12.1 24
[SwitchA-Vlanif100] quit
[SwitchA] interface vlanif 400
[SwitchA-Vlanif400] ip address 192.168.14.1 24
[SwitchA-Vlanif400] quit
  •  3.配置PC1–PC2的去程的静态路由

  # 配置SwitchA,配置两条优先级不同的静态路由,下一跳分别指向SwitchB和SwitchD,实现数据流优先发往SwitchB,当去往SwitchB的链路发生故障的时候流量自动切换至SwitchD。

[SwitchA] ip route-static 10.1.2.0 24 192.168.12.2
[SwitchA] ip route-static 10.1.2.0 24 192.168.14.2 preference 70

   # 配置SwitchB。

[SwitchB] ip route-static 10.1.2.0 24 192.168.23.2

   # 配置SwitchD。

[SwitchD] ip route-static 10.1.2.0 24 192.168.34.1
  •  4.配置PC1–PC2的回程的静态路由,需要注意数据流来回的路径主备是一致的。

  # 配置SwitchC,配置两条优先级不同的静态路由,下一跳分别指向SwitchB和SwitchD,实现数据流优先发往SwitchB,当去往SwitchB的链路发生故障的时候流量自动切换至SwitchD。

[SwitchC] ip route-static 10.1.1.0 24 192.168.23.1
[SwitchC] ip route-static 10.1.1.0 24 192.168.34.2 preference 70

   # 配置SwitchB。

[SwitchB] ip route-static 10.1.1.0 24 192.168.12.1

   # 配置SwitchD。

[SwitchD] ip route-static 10.1.1.0 24 192.168.14.1
  •  5.配置主机
相关阅读  静态路由实现主备备份

  配置主机PC1的IP地址为10.1.1.2/24,默认网关为10.1.1.1;配置主机PC2的IP地址为10.1.2.2/24,默认网关为10.1.2.1。

  • 6.验证配置结果

  #查看SwitchA的IP路由表。

[SwitchA] display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
         Destinations : 9        Routes : 9        

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

       10.1.1.0/24  Direct  0    0           D   10.1.1.1        Vlanif10
       10.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10
       10.1.2.0/24  Static  60   0          RD   192.168.12.2    Vlanif100
      127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
      127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
   192.168.12.0/24  Direct  0    0           D   192.168.12.1    Vlanif100
   192.168.12.1/32  Direct  0    0           D   127.0.0.1       Vlanif100
   192.168.14.0/24  Direct  0    0           D   192.168.14.1    Vlanif400
   192.168.14.1/32  Direct  0    0           D   127.0.0.1       Vlanif400

   #查看SwitchA的IP路由表详细信息。

[SwitchA] display ip routing-table 10.1.2.0 24 verbose
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Table : Public
Summary Count : 2

Destination: 10.1.2.0/24
     Protocol: Static          Process ID: 0
   Preference: 60                    Cost: 0
      NextHop: 192.168.12.2     Neighbour: 0.0.0.0
        State: Active Adv Relied      Age: 00h13m13s
          Tag: 0                 Priority: medium
        Label: NULL               QoSInfo: 0x0
   IndirectID: 0x80000001       
 RelayNextHop: 0.0.0.0          Interface: Vlanif100
     TunnelID: 0x0                  Flags: RD

Destination: 10.1.2.0/24
     Protocol: Static          Process ID: 0
   Preference: 70                    Cost: 0
      NextHop: 192.168.14.2     Neighbour: 0.0.0.0
        State: Inactive Adv Relied    Age: 00h00m45s
          Tag: 0                 Priority: medium
        Label: NULL               QoSInfo: 0x0
   IndirectID: 0x80000002       
 RelayNextHop: 0.0.0.0          Interface: Vlanif400
     TunnelID: 0x0                  Flags: R

   从SwitchA的IP路由表中可以看出,到达10.1.2.0/24这个网段仅有一条活跃的路由,链路正常情况下从PC1发往PC2的数据流会优先算则走经过SwitchB的这条路径。从SwitchA的IP路由表详细信可以看出,到达10.1.2.0/24这个网段除了有一条状态为Active的路由,还有一条状态为Inactive的路由,当主用链路故障的时候状态为Inactive的路由就会重新生效,这样流量就能切换到经过SwitchD的这条路径上。这样就能通过静态路由实现路由的主备备份。

相关阅读  FRP 内网穿透搭建(全)

 


AD:【腾讯云服务器大降价】2核4G 222元/3年 1核2G 38元/年

AD:【腾讯云服务器大降价】2核4G 222元/3年 1核2G 38元/年

AD:【腾讯云服务器大降价】2核4G 222元/3年 1核2G 38元/年

AD:【腾讯云服务器大降价】2核4G 222元/3年 1核2G 38元/年

本文来自一日成建站教程https://www.yiricheng.cn/),为广大编程爱好者提供零基础快速搭建博客网站的方法,分享计算机网络、HTML、CSS,、JavaScript、PHP、响应式设计以及Python自动化办公的博客文章,另有各类小工具、电子书、免费教程。