配置VRRP主备功能

组网图形

    

 VRRP主备备份简介

  • 通常,同一网段内的所有主机上都存在一条相同的、以网关为下一跳的缺省路由。主机发往其他网段的报文将通过缺省路由发往网关,再由网关进行转发,从而实现主机与外部网络的通信。当网关发生故障时,本网段内所有以网关为缺省路由的主机将无法与外部网络通信。增加出口网关是提高系统可靠性的常见方法,此时如何在多个出口之间进行选路就成为需要解决的问题。
  • VRRP的出现很好的解决了这个问题。VRRP能够在不改变组网的情况下,采用将多台路由设备组成一个虚拟路由器,通过配置虚拟路由器的IP地址为默认网关,实现默认网关的备份。当网关设备发生故障时,VRRP机制能够选举新的网关设备承担数据流量,从而保障网络通信的可靠性。
  • 在配置VRRP备份组内各交换机时,建议将Backup配置为立即抢占,即不延迟(延迟时间为0),而将Master配置为延时抢占,并且配置15秒以上的延迟时间。这样配置的目的是为了在网络环境不稳定时,在上下行链路的状态恢复一致性期间等待一定时间,避免由于双方频繁抢占导致用户设备学习到错误的Master设备地址而导致流量中断问题。
    • 抢占模式:在抢占模式下,如果Backup设备的优先级比当前Master设备的优先级高,则主动将自己切换成Master。

    • 非抢占模式:在非抢占模式下,只要Master设备没有出现故障,Backup设备即使随后被配置了更高的优先级也不会成为Master设备。

说明:
•保证同一备份组的设备上配置相同的备份组号(virtual-router-id)。
•不同备份组之间的虚拟IP地址不能重复,并且必须和接口的IP地址在同一网段。

  VRRP负载分担(详情见)与VRRP主备备份方式不同点在于:

  • 负载分担方式需要建立多个VRRP备份组,各备份组的Master设备可以不同。
  • 同一台VRRP设备可以加入多个备份组,在不同的备份组中具有不同的优先级。

组网需求

  • 如图1所示,HostA通过Switch双归属到SwitchA和SwitchB。为保证用户的各种业务在网络传输中不中断,需在SwitchA和SwitchB上配置VRRP主备备份功能。
  • 正常情况下,主机以SwitchA为默认网关接入Internet,当SwitchA故障时,SwitchB接替SwitchA作为网关继续进行工作,实现网关的冗余备份。
  • SwitchA故障恢复后,其延时20秒通过抢占的方式重新成为Master,承担数据传输。

配置思路

  • 1.配置各设备接口IP地址及路由协议,使各设备间网络层连通。
  • 2.在SwitchA和SwitchB上配置VRRP备份组。其中,SwitchA上配置较高优先级和20秒抢占延时,作为Master设备承担流量转发;SwitchB上配置较低优先级,作为备用交换机,实现网关冗余备份。

操作步骤

  • 1.配置设备间的网络互连

  # 配置设备各接口的IP地址,以SwitchA为例。SwitchB和SwitchC的配置与SwitchA类似,不再赘述。

<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] vlan batch 100 300
[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] port link-type hybrid
[SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 300
[SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 300
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] port link-type hybrid
[SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 100
[SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 100
[SwitchA-GigabitEthernet1/0/2] quit
[SwitchA] interface vlanif 100
[SwitchA-Vlanif100] ip address 10.1.1.1 24
[SwitchA-Vlanif100] quit
[SwitchA] interface vlanif 300
[SwitchA-Vlanif300] ip address 192.168.1.1 24
[SwitchA-Vlanif300] quit

   # 配置Switch的二层转发功能。

<HUAWEI> system-view
[HUAWEI] sysname Switch
[Switch] vlan 100
[Switch-vlan100] quit
[Switch] interface gigabitethernet 1/0/1
[Switch-GigabitEthernet1/0/1] port link-type hybrid
[Switch-GigabitEthernet1/0/1] port hybrid pvid vlan 100
[Switch-GigabitEthernet1/0/1] port hybrid untagged vlan 100
[Switch-GigabitEthernet1/0/1] quit
[Switch] interface gigabitethernet 1/0/2
[Switch-GigabitEthernet1/0/2] port link-type hybrid
[Switch-GigabitEthernet1/0/2] port hybrid pvid vlan 100
[Switch-GigabitEthernet1/0/2] port hybrid untagged vlan 100
[Switch-GigabitEthernet1/0/2] quit

   # 配置SwitchA、SwitchB和SwitchC间采用OSPF协议进行互连。以SwitchA为例,SwitchB和SwitchC的配置与SwitchA类似,不再赘述。

[SwitchA] ospf 1
[SwitchA-ospf-1] area 0
[SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
[SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
[SwitchA-ospf-1-area-0.0.0.0] quit
[SwitchA-ospf-1] quit
  •  2.配置VRRP备份组
相关阅读  frp+proxifier实现内网socks5反向代理

  # 在SwitchA上创建VRRP备份组1,配置SwitchA在该备份组中的优先级为120,并配置抢占时间为20秒。

[SwitchA] interface vlanif 100
[SwitchA-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.111
[SwitchA-Vlanif100] vrrp vrid 1 priority 120                  //设备在VRRP备份组中的优先级缺省为100,修改Master设备的优先级大于Backup设备
[SwitchA-Vlanif100] vrrp vrid 1 preempt-mode timer delay 20   //设备在VRRP备份组中缺省采用立即抢占方式。修改Master设备的延迟抢占时间,以避免在网络环境不稳定时,由于双方频繁抢占而导致流量中断的问题
[SwitchA-Vlanif100] quit

   # 在SwitchB上创建VRRP备份组1,其在该备份组中的优先级采用缺省值100(不需要配置)。

[SwitchB] interface vlanif 100
[SwitchB-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.111
[SwitchB-Vlanif100] quit
  •  3.验证配置结果

  # 完成上述配置以后,在SwitchA和SwitchB上分别执行display vrrp命令,可以看到SwitchA在备份组中的状态为Master,SwitchB在备份组中的状态为Backup。

[SwitchA] display vrrp
  Vlanif100 | Virtual Router 1
    State : Master
    Virtual IP : 10.1.1.111
    Master IP : 10.1.1.1
    PriorityRun : 120
    PriorityConfig : 120                                                        
    MasterPriority : 120                                                        
    Preempt : YES   Delay Time : 20 s
    TimerRun : 1 s
    TimerConfig : 1 s
    Auth type : NONE                                                            
    Virtual MAC : 0000-5e00-0101                                                
    Check TTL : YES                                                             
    Config type : normal-vrrp                                                   
    Backup-forward : disabled
    Create time : 2018-07-12 20:15:46
    Last change time : 2018-07-12 20:15:46
[SwitchB] display vrrp
  Vlanif100 | Virtual Router 1
    State : Backup
    Virtual IP : 10.1.1.111
    Master IP : 10.1.1.1
    PriorityRun : 100
    PriorityConfig : 100                                                        
    MasterPriority : 120                                                        
    Preempt : YES   Delay Time : 0 s
    TimerRun : 1 s
    TimerConfig : 1 s
    Auth type : NONE                                                            
    Virtual MAC : 0000-5e00-0101                                                
    Check TTL : YES                                                             
    Config type : normal-vrrp                                                   
    Backup-forward : disabled
    Create time : 2018-07-12 20:15:46
    Last change time : 2018-07-12 20:15:46

   # 在SwitchA和SwitchB上执行display ip routing-table命令,SwitchA上可以看到路由表中有一条目的地址为虚拟IP地址的直连路由,而SwitchB上该路由为OSPF路由。SwitchA和SwitchB上的显示信息如下。

[SwitchA] display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------  
Routing Tables: Public                                                          
         Destinations : 9       Routes : 10                                    
                                                                                
Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                
     10.1.1.0/24    Direct   0     0         D      10.1.1.1        Vlanif100
     10.1.1.1/32    Direct   0     0         D      127.0.0.1       Vlanif100
 10.1.1.111/32    Direct  0     0         D      127.0.0.1      Vlanif100
     127.0.0.0/8    Direct   0    0          D      127.0.0.1       InLoopBack0
    127.0.0.1/32    Direct   0    0          D      127.0.0.1       InLoopBack0
   172.16.1.0/24    OSPF     10   2          D      192.168.1.2     Vlanif300
  192.168.1.0/24    Direct   0    0          D      192.168.1.1     Vlanif300
  192.168.1.1/32    Direct   0    0          D      127.0.0.1       Vlanif300
  192.168.2.0/24    OSPF     10   2          D      10.1.1.2        Vlanif100
                    OSPF     10   2          D      192.168.1.2     Vlanif300
[SwitchB] display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------  
Routing Tables: Public                                                          
         Destinations : 9       Routes : 10                                    
                                                                                
Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                
     10.1.1.0/24    Direct   0     0         D     10.1.1.2        Vlanif100
     10.1.1.2/32    Direct   0     0         D     127.0.0.1       Vlanif100
 10.1.1.111/32    OSPF    10    2         D     10.1.1.1       Vlanif100
     127.0.0.0/8    Direct   0     0         D     127.0.0.1       InLoopBack0
    127.0.0.1/32    Direct   0     0         D     127.0.0.1       InLoopBack0
   172.16.1.0/24    OSPF     10    2         D     192.168.2.2     Vlanif200
  192.168.1.0/24    OSPF     10    2         D     10.1.1.1        Vlanif100
                    OSPF     10    2         D     192.168.2.2     Vlanif200
  192.168.2.0/24    Direct   0     0         D     192.168.2.1     Vlanif200
  192.168.2.1/32    Direct   0     0         D     127.0.0.1       Vlanif200

   # 在SwitchA的接口GE1/0/2上执行shutdown命令,模拟SwitchA出现故障。

[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] shutdown
[SwitchA-GigabitEthernet1/0/2] quit

   # 在SwitchB上执行display vrrp命令查看VRRP状态信息,可以看到SwitchB的状态是Master。

[SwitchB] display vrrp
  Vlanif100 | Virtual Router 1
    State : Master
    Virtual IP : 10.1.1.111
    Master IP : 10.1.1.2
    PriorityRun : 100
    PriorityConfig : 100                                                        
    MasterPriority : 100                                                        
    Preempt : YES   Delay Time : 0 s
    TimerRun : 1 s
    TimerConfig : 1 s
    Auth type : NONE                                                            
    Virtual MAC : 0000-5e00-0101                                                
    Check TTL : YES                                                             
    Config type : normal-vrrp                                                   
    Backup-forward : disabled
    Create time : 2018-07-12 20:15:46
    Last change time : 2018-07-12 20:18:40

   # 在SwitchA的接口GE1/0/2上执行undo shutdown命令。

[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] undo shutdown
[SwitchA-GigabitEthernet1/0/2] quit

   # 等待20秒后,在SwitchA上执行display vrrp命令查看VRRP状态信息,可以看到SwitchA的状态恢复成Master。

[SwitchA] display vrrp
  Vlanif100 | Virtual Router 1
    State : Master
    Virtual IP : 10.1.1.111
    Master IP : 10.1.1.1
    PriorityRun : 120
    PriorityConfig : 120                                                        
    MasterPriority : 120                                                        
    Preempt : YES   Delay Time : 20 s
    TimerRun : 1 s
    TimerConfig : 1 s
    Auth type : NONE                                                            
    Virtual MAC : 0000-5e00-0101                                                
    Check TTL : YES                                                             
    Config type : normal-vrrp                                                   
    Backup-forward : disabled
    Create time : 2018-07-12 20:15:46
    Last change time : 2018-07-12 20:20:56

 

相关阅读  计算机网络面试题

AD:【腾讯云服务器大降价】2核4G 222元/3年 1核2G 38元/年

AD:【腾讯云服务器大降价】2核4G 222元/3年 1核2G 38元/年

AD:【腾讯云服务器大降价】2核4G 222元/3年 1核2G 38元/年

AD:【腾讯云服务器大降价】2核4G 222元/3年 1核2G 38元/年

本文来自一日成建站教程https://www.yiricheng.cn/),为广大编程爱好者提供零基础快速搭建博客网站的方法,分享计算机网络、HTML、CSS,、JavaScript、PHP、响应式设计以及Python自动化办公的博客文章,另有各类小工具、电子书、免费教程。