如何实现IP话机接入交换机?

组网图形

    

简介

  • 如果语音设备支持LLDP协议,并且支持通过network-policy TLV字段获取语音VLAN,可以在交换机上配置命令lldp tlv-enable med-tlv network-policy voice-vlan为语音设备分配Voice VLAN,然后再通过Voice VLAN功能提升语音报文的优先级。

组网需求

  • 如图所示,用户为了节省投资成本,希望通过VoIP实现IP话机接入网络。用户的IP话机支持LLDP协议,同时支持通过LLDP协议的network-policy TLV字段获取语音VLAN和报文的优先级。为了保证IP话机的正常接入,用户希望网络规划满足如下要求:
  • IP话机发送的语音报文,可以携带VLAN Tag,且优先级比较高,不需要交换机再进行提升。
  • 语音流使用VLAN 100进行通信。
  • IP话机的IP地址通过DHCP服务器动态分配,且IP话机的IP地址和DHCP服务器的IP地址不在同一个网段。
  • 网络环境较安全,IP话机不需要认证就可以上线。

 配置思路

  • 采用如下的思路配置通过LLDP_MED实现IP话机接入交换机:
  1. 全局和接口使能LLDP功能,通过在接口配置network-policy TLV为IP话机分配语音VLAN和优先级。
  2. 接口加入VLAN,实现语音报文的转发。
  3. IP话机发送的语音报文优先级较高,配置接口信任报文的优先级。
  4. 配置DHCP Relay和DHCP Server功能,为IP话机分配IP地址。
  5. 配置AAA域,对IP话机进行管理,同时使能语音设备不认证即可上线的功能。

操作步骤

  • 1.使能SwitchA的LLDP功能,同时配置接口上network-policy TLV的值

  # 全局使能LLDP功能。

<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] lldp enable  //全局使能LLDP后,所有接口默认自动使能LLDP

   # 配置接口上network-policy TLV的值。

[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] lldp tlv-enable med-tlv network-policy voice-vlan vlan 100 cos 6 dscp 60  //配置LLDP_MED分配给IP话机的语音VLAN和优先级
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] lldp tlv-enable med-tlv network-policy voice-vlan vlan 100 cos 6 dscp 60  //配置LLDP_MED分配给IP话机的语音VLAN和优先级
[SwitchA-GigabitEthernet1/0/2] quit
  •  2.把SwitchA的接口加入VLAN

  # 创建VLAN100。

[SwitchA] vlan batch 100  //语音流使用VLAN 100进行通信

   # 把接口加入VLAN 100。

[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] port link-type hybrid   //其中V200R005C00及之后版本,默认接口类型不是hybrid,需要手动配置
[SwitchA-GigabitEthernet1/0/1] port hybrid tagged vlan 100  //接口以Tagged方式加入语音VLAN 100
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] port link-type hybrid
[SwitchA-GigabitEthernet1/0/2] port hybrid tagged vlan 100
[SwitchA-GigabitEthernet1/0/2] quit
  •  3.配置接口信任报文的优先级
[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] trust 8021p inner  //trust 8021p (inner)命令因设备形态不同有所区别,具体配置请以设备为准
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] trust 8021p inner  //trust 8021p (inner)命令因设备形态不同有所区别,具体配置请以设备为准
[SwitchA-GigabitEthernet1/0/2] quit
  •  4.配置DHCP Relay和DHCP Server功能
  1. 配置SwitchA为DHCP Relay功能

    # 配置接口的DHCP Relay功能。

[SwitchA] dhcp enable  //全局使能DHCP功能,缺省未使能
[SwitchA] interface Vlanif 100  //创建VLANIF100
[SwitchA-Vlanif100] ip address 10.20.20.1 255.255.255.0  //配置VLANIF100的IP地址
[SwitchA-Vlanif100] dhcp select relay  //使能VLANIF接口DHCP中继功能
[SwitchA-Vlanif100] dhcp relay server-ip 10.10.20.2  //配置DHCP中继所代理的DHCP服务器地址
[SwitchA-Vlanif100] quit

   # 创建VLANIF 200。

[SwitchA] vlan batch 200
[SwitchA] interface Vlanif 200
[SwitchA-Vlanif200] ip address 10.10.20.1 255.255.255.0  //配置VLANIF200的IP地址,用于和SwitchB交互
[SwitchA-Vlanif200] quit

   # 把上行接口加入VLAN 200。

[SwitchA] interface gigabitethernet 1/0/3
[SwitchA-GigabitEthernet1/0/3] port link-type hybrid
[SwitchA-GigabitEthernet1/0/3] port hybrid pvid vlan 200
[SwitchA-GigabitEthernet1/0/3] port hybrid untagged vlan 200
[SwitchA-GigabitEthernet1/0/3] quit

   # 配置缺省静态路由。

[SwitchA] ip route-static 0.0.0.0 0.0.0.0 10.10.20.2  //该路由的下一跳对应SwitchB VLANIF200的IP地址

   b.配置SwitchB为DHCP Server,为IP话机分配IP地址

相关阅读  WordPress开启SSL证书http转https的设置方法

  # 配置地址池。

<HUAWEI> system-view
[HUAWEI] sysname SwitchB
[SwitchB] ip pool ip-phone  //创建一个地址池
[SwitchB-ip-pool-ip-phone] gateway-list 10.20.20.1  //配置DHCP服务器的出口网关地址
[SwitchB-ip-pool-ip-phone] network 10.20.20.0 mask 255.255.255.0  //配置该地址池可以分配的网段地址
[SwitchB-ip-pool-ip-phone] quit

   # 配置DHCP Server功能。

[SwitchB] dhcp enable  //全局使能DHCP功能,缺省未使能
[SwitchB] vlan batch 200
[SwitchB] interface Vlanif 200  //创建VLANIF200
[SwitchB-Vlanif200] ip address 10.10.20.2 255.255.255.0  //配置VLANIF的IP地址
[SwitchB-Vlanif200] dhcp select global  //配置接口采用全局地址池方式为话机分配IP地址
[SwitchB-Vlanif200] quit

   # 把下行接口加入VLAN 200。

[SwitchB] interface gigabitethernet 1/0/3
[SwitchB-GigabitEthernet1/0/3] port link-type hybrid
[SwitchB-GigabitEthernet1/0/3] port hybrid pvid vlan 200
[SwitchB-GigabitEthernet1/0/3] port hybrid untagged vlan 200
[SwitchB-GigabitEthernet1/0/3] quit

   # 配置回程路由。

[SwitchB] ip route-static 10.20.20.0 255.255.255.0 10.10.20.1
  •  5.配置AAA域并使能语音设备不认证即上线的功能
  1. 配置AAA认证域

    # 创建并配置RADIUS服务器模板。

[SwitchA] radius-server template cisco  //创建名为"cisco"的RADIUS服务器模板
[SwitchA-radius-cisco] radius-server authentication 192.168.6.182 1812  //配置RADIUS认证服务器的IP地址和端口号
[SwitchA-radius-cisco] radius-server accounting 192.168.6.182 1813  //配置RADIUS计费服务器的IP地址和端口号
[SwitchA-radius-cisco] quit

   # 配置业务方案和认证方案。

[SwitchA] aaa
[SwitchA-aaa] service-scheme cisco  //创建AAA业务方案为“cisco”
[SwitchA-aaa-service-cisco] quit
[SwitchA-aaa] authentication-scheme radius  //配置认证方案为RADIUS
[SwitchA-aaa-authen-radius] authentication-mode radius  //配置认证方式为RADIUS
[SwitchA-aaa-authen-radius] quit

   # 创建AAA域并配置default域。

[SwitchA-aaa] domain default  //配置default认证域
[SwitchA-aaa-domain-default] authentication-scheme radius  //绑定AAA认证方案“radius”
[SwitchA-aaa-domain-default] radius-server cisco  //绑定RADIUS服务器模板“cisco”
[SwitchA-aaa-domain-default] service-scheme cisco  //绑定业务模板“cisco”
[SwitchA-aaa-domain-default] quit
[SwitchA-aaa] quit

   b.使能语音设备不认证即上线的功能

  # 将NAC配置模式切换成统一模式。

[SwitchA] authentication unified-mode  //设备默认为统一模式。传统模式与统一模式相互切换后,管理员必须保存配置后重启设备,新配置模式的各项功能才能生效

 # 使能语音设备不认证即上线的功能。

[SwitchA] authentication device-type voice authorize service-scheme cisco

   # 配置认证模板。

[SwitchA] authentication-profile name cisco  //创建认证模板“cisco”
[SwitchA-authen-profile-cisco] authentication device-type voice authorize service-scheme cisco  //使能语音终端不认证即上线功能
[SwitchA-authen-profile-cisco] quit

   # 在接口上应用认证模板。

[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] authentication-profile cisco  //绑定认证模板
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] authentication-profile cisco
[SwitchA-GigabitEthernet1/0/2] quit
  •  6.检查配置结果
  • 通过IP话机的菜单查看IP话机可以正常获取到正确的语音VLAN和IP地址。
  • 在SwitchA上执行命令display mac-address vlan 100,可以看到IP话机的接入信息。
[SwitchA] display mac-address vlan 100
-------------------------------------------------------------------------------                                                     
MAC Address    VLAN/VSI                       Learned-From        Type                                                           
-------------------------------------------------------------------------------                                                     
001b-d4c7-1fa9 100/-                          GE1/0/1             dynamic                                                         
0021-a08f-2fa8 100/-                          GE1/0/2             dynamic                                                         
                                                                                                                                    
-------------------------------------------------------------------------------

 

相关阅读  OSPF协议介绍及配置 (下)

AD:【腾讯云服务器大降价】2核4G 222元/3年 1核2G 38元/年

AD:【腾讯云服务器大降价】2核4G 222元/3年 1核2G 38元/年

AD:【腾讯云服务器大降价】2核4G 222元/3年 1核2G 38元/年

AD:【腾讯云服务器大降价】2核4G 222元/3年 1核2G 38元/年

本文来自一日成建站教程https://www.yiricheng.cn/),为广大编程爱好者提供零基础快速搭建博客网站的方法,分享计算机网络、HTML、CSS,、JavaScript、PHP、响应式设计以及Python自动化办公的博客文章,另有各类小工具、电子书、免费教程。