交换机基于接口划分VLAN(汇聚层设备作为网关)

组网图形

 简介

  • 划分VLAN的方式有:基于接口、基于MAC地址、基于IP子网、基于协议、基于策略(MAC地址、IP地址、接口)。其中基于接口划分VLAN,是最简单,最常见的划分方式,如接入层设备作为网关(详情见)和汇聚层设备作为网关。
  • 基于接口划分VLAN指的是根据交换机的接口来划分VLAN。网络管理员预先给交换机的每个接口配置不同的PVID,当一个数据帧进入交换机时,如果没有带VLAN标签,该数据帧就会被打上接口指定PVID的Tag,然后数据帧将在指定PVID中传输。
  • 在典型的分层组网中,当接入交换机是二层交换机时,可以使用汇聚交换机作为用户的网关。另外使用汇聚交换机作为用户的网关还可以简化接入交换机的配置,使用户通过一个出接口访问外部网络,便于维护和管理。

组网需求

  • 如图所示,PC1和PC2分别属于VLAN 2和VLAN 3,通过接入交换机SW2接入汇聚交换机SW1。PC3属于VLAN 4,通过SW3接入汇聚交换机SW1。SW3不做任何配置,当做HUB即插即用。汇聚交换机SW1作为PC1、PC2和PC3的网关,实现用户PC间的互访以及和路由器的互连。

配置思路

  • 配置接入交换机,基于接口划分VLAN,实现二层互通。
  • 配置汇聚交换机作为用户PC的网关,实现不同网段用户PC间的三层互通。
  • 配置汇聚交换机与路由器相连的接口,实现与路由器的互连。

操作步骤

  • 配置接入交换机SW2

  # 创建VLAN。

<HUAWEI> system-view
[HUAWEI] sysname SW2  //修改设备的名称为SW2,便于识别
[SW2] vlan batch 2 3  //批量创建VLAN 2和VLAN 3

   # 将接口加入相应VLAN。

[SW2] interface gigabitethernet 1/0/23
[SW2-GigabitEthernet1/0/23] port link-type access  //将与PC相连接口的接口类型设置为access
[SW2-GigabitEthernet1/0/23] port default vlan 2  //将PC1划分到VLAN 2
[SW2-GigabitEthernet1/0/23] quit
[SW2] interface gigabitethernet 1/0/24
[SW2-GigabitEthernet1/0/24] port link-type access
[SW2-GigabitEthernet1/0/24] port default vlan 3  //将PC2划分到VLAN 3
[SW2-GigabitEthernet1/0/24] quit
[SW2] interface gigabitethernet 1/0/1
[SW2-GigabitEthernet1/0/1] port link-type trunk  //将与汇聚交换机相连接口的接口类型设置为trunk
[SW2-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 3  //透传VLAN 2和VLAN 3到汇聚交换机SW1
[SW2-GigabitEthernet1/0/1] quit
  •  配置汇聚交换机SW1

  # 创建VLAN。

<HUAWEI> system-view
[HUAWEI] sysname SW1  //修改设备的名称为SW1
[SW1] vlan batch 2 to 5  //批量创建VLAN 2到VLAN 5

   # 将连接PC的接口加入相应VLAN。

[SW1] interface gigabitethernet 1/0/2
[SW1-GigabitEthernet1/0/2] port link-type trunk  //将与SW1相连接口的接口类型设置为trunk
[SW1-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 3  //透传VLAN 2和VLAN 3
[SW1-GigabitEthernet1/0/2] quit
[SW1] interface gigabitethernet 1/0/3
[SW1-GigabitEthernet1/0/3] port link-type access  //将与PC3相连接口的接口类型设置为access
[SW1-GigabitEthernet1/0/3] port default vlan 4  //将PC3划分到VLAN 4
[SW1-GigabitEthernet1/0/3] quit

   # 配置VLANIF接口,作为用户PC的网关。

[SW1] interface vlanif 2  //创建VLANIF2接口
[SW1-Vlanif2] ip address 192.168.2.1 24  //配置IP地址,此IP地址是PC1的网关地址
[SW1-Vlanif2] quit
[SW1] interface vlanif 3  //创建VLANIF3接口
[SW1-Vlanif3] ip address 192.168.3.1 24  //配置IP地址,此IP地址是PC2的网关地址
[SW1-Vlanif3] quit
[SW1] interface vlanif 4  //创建VLANIF4接口
[SW1-Vlanif4] ip address 192.168.4.1 24  //配置IP地址,此IP地址是PC3的网关地址
[SW1-Vlanif4] quit

   # 将连接路由器的接口加入相应VLAN。

[SW1] interface gigabitethernet 1/0/1
[SW1-GigabitEthernet1/0/1] port link-type access  //将与路由器相连接口的接口类型设置为access,与路由器通过Untagged方式通信
[SW1-GigabitEthernet1/0/1] port default vlan 5  //将路由器划分到VLAN 5
[SW1-GigabitEthernet1/0/1] quit

   # 配置VLANIF接口,实现和路由器的互连。

[SW1] interface vlanif 5  //创建VLANIF5接口
[SW1-Vlanif5] ip address 192.168.5.1 24  //配置IP地址,此IP地址是与路由器对接的IP地址
[SW1-Vlanif5] quit
  •  检查配置结果
相关阅读  虚拟机装win2003配置iis同一个ip和端口号放多个网站

  PC1、PC2、PC3之间可以相互访问,同时PC都可以和路由器进行通信。

 


AD:【腾讯云服务器大降价】2核4G 222元/3年 1核2G 38元/年

AD:【腾讯云服务器大降价】2核4G 222元/3年 1核2G 38元/年

AD:【腾讯云服务器大降价】2核4G 222元/3年 1核2G 38元/年

AD:【腾讯云服务器大降价】2核4G 222元/3年 1核2G 38元/年

本文来自一日成建站教程https://www.yiricheng.cn/),为广大编程爱好者提供零基础快速搭建博客网站的方法,分享计算机网络、HTML、CSS,、JavaScript、PHP、响应式设计以及Python自动化办公的博客文章,另有各类小工具、电子书、免费教程。